24. VPN (Virtual Private Network)

vpn

Overview

Tentunya pembaca sudah banyak tahu apa itu VPN. Sederhananya, VPN adalah protokol yang menghubungkan jaringan secara private. Misalkan perusahan A memilii kantor di Jogja dan Jakarta. Maka kedua kantor tersebut dapat terhubung dengan membangun suatu koneksi private melalui jaringan internet. Jadi seakan-akan kedua kantor tersebut terhubung secara langsung dalam satu jaringan.

Pada cisco, protokol yang digunakan untuk membangun VPN adalah GRE. Jika ingin mencari teori yang lebih detail dapat mencari referensi di buku-buku atau di internet.

Konfigurasi VPN

VPN

Konfigurasi IP address pada semua perangkat sesuai dengan topologi di atas. Kemudian implementasikan protokol routing EIGRP pada router-router tersebut. Jangan libatkan NET-A dan NET-B pada EIGRP. Pastikan R1 dapat melakukan ping ke R3.

Kemudian lakukan konfigurasi VPN pada R1 dan R3. Network yang digunakan untuk tunnel VPN adalah 172.16.1.0/24.

R1(config)# int tunnel 1
R1(config-if)# ip add 172.16.1.1 255.255.255.0
R1(config-if)# tunnel source g0/1
R1(config-if)# tunnel destination 23.23.23.3
R3(config)# int tunnel 1
R3(config-if)# ip add 172.16.1.254 255.255.255.0
R3(config-if)# tunnel source g0/2
R3(config-if)# tunnel destination 12.12.12.1

Lakukan tes ping ke interface tunnel dari R1 ke R3. Pastikan VPN sudah berjalan dengan baik.

R1# ping 172.16.1.254

Pada network NET-A dan NET-B belum dapat terhubung melalui VPN. Untuk itu perlu dilakukan konfigurasi routing antara NET-A dan NET-B dengan jaringan VPN.

R1(config)# router ospf 1
R1(config-router)# network 172.16.1.0 0.0.0.255 area 0
R1(config-router)# network 192.168.10.0 0.0.0.255 area 0
R3(config)# router ospf 1
R3(config-router)# network 172.16.1.0 0.0.0.255 area 0
R3(config-router)# network 192.168.30.0 0.0.0.255 area 0

Kemudian lakukan ping dari PC di NET-A ke NET-B atau sebaliknya. Dan juga lakukan trace antar kedua network tersebut. Jika ping berhasil dan hasil trace menunjukkan bahwa paket dikirim melalui jaringan VPN, maka VPN sudah berjalan baik di kedua network tersebut.

Hasil tracert dari PC di NET-B ke PC di NET-A

Hasil tracert di atas menunjukkan bahwa paket yang dikirimkan dari 192.168.30.3 menuju 192.168.10.11 melewati jaringan VPN dengan gateway 172.16.1.1.


LANJUTKAN BACA MATERI LENGKAP


Leave a Reply

Your email address will not be published.

This site uses Akismet to reduce spam. Learn how your comment data is processed.