16. Multi Area OSPF

Screenshot_74

Overview

  • OSPF tidak cocok untuk jaringan dengan skala yang sangat besar.
  • Ketika jaringan berkembang, dibutuhkan space yang lebih untuk penyimpanan database.
  • Kompleksitas algoritma SPF secara logaritma tergantung pada jumlah router. Dengan on/off nya interface di dalam sebuah AS, algoritma SPF harus tetap berjalan.
  • Cisco merekomendasikan tidak menempatkan lebih dari 50 router dalam sebuah area.
  • OSPF Multi Area adalah solusi untuk membuat OSPF menjadi lebih scalable.
  • Tipe Area:
    • Backbone Area (area 0)
    • Normal Area
  • Aturan Desain Area:
    • Semua Normal Area harus terkoneksi dengan Backbone Area.
    • Harus ada konektivitas antar Normal Area.
    • Backbone Area harus berkelanjutan.
  • LSA dan Route
    • Intra Area Routes (O) : Rute yang dipelajari dari router di dalam internal area.
    • Inter Area Routes (OIA) : Rute yang dipelajari dari router ABR.
    • External Routes (OE1/OE2) : Rute yang dipelajari dari router ASBR.

Administrative Distance (AD)

Adminitrative Distance (AD) adalah sebuah parameter untuk membandingkan protokol routing yang berbeda. Jika sebuah router mempunyai lebih dari satu rute untuk mencapai suatu tujuan dengan protokol routing yang berbeda, maka akan digunakan Administrative Distance untuk menentukan rute terbaik.

Dalam kasus ini metric tidak dapat digunakan karena pada masing-masing protokol routing akan memiliki perbedaan persepsi. AD dengan nilai terkecil akan dipilih dan ditempatkan pada tabel routing.

  • Reliability
    • EGP lebih reliable dari pada IGP.
    • Static lebih reliable dari pada dinamis.
  • Metric
    • RIP: Berdasarkan jumlah router pada sebuah jalur.
    • OSPF: Berdasarkan total bandwidth pada sebuah jalur.
    • EIGRP: Berdasarkan bandwidth terkecil pada sebuah jalur.
Administrative Distance

Praktik 1 – Multi Area OSPF

Multi Area OSPF
R1(config)# router ospf 1
R1(config-router)# router-id 1.1.1.1
R1(config-router)# network 11.11.11.0 0.0.0.255 area 11
R2(config)# router ospf 1
R2(config-router)# router-id 2.2.2.2
R2(config-router)# network 10.10.10.0 0.0.0.255 area 0
R2(config-router)# network 11.11.11.0 0.0.0.255 area 11
R3(config)# router ospf 1
R3(config-router)# router-id 3.3.3.3
R3(config-router)# network 10.10.10.0 0.0.0.255 area 0
R3(config-router)# network 12.12.12.0 0.0.0.255 area 12
R4(config)# router ospf 1
R4(config-router)# router-id 4.4.4.4
R4(config-router)# network 12.12.12.0 0.0.0.255 area 12

Lihat pada tabel routing pada masing-masing router. Jika rute ospf sudah didapatkan maka cobalah untuk melakukan uji coba ping dari Area 11 ke Area 12.

R1# show ip route
Hasil perintah show ip route

Terlihat rute yang didapatkan dari protokol OSPF yaitu network 10.10.10.0/24 dan 12.12.12.0/24 dengan label O IA yang menandakan bahwa rute di dalam tabel routing tersebut didapatkan dari router ABR.

Praktik 2 – Multi Area OSPF + RIP

Multi Area OSPF + RIP

Pada praktik yang ke-2 ini agak sedikit berbeda yaitu Multi Area OSPF digabungkan dengan RIP. Untuk konfigurasi sebenernya tidak jauh berbeda. Jaringan yang menghubungkan R1 dan RIP menggunakan protokol RIP. Jika dilihat dari gambar di atas, maka R1 mempunyai 2 routing protokol sekaligus yaitu OSPF dan RIP.

R2(config)# interface Loopback1
R2(config-if)# ip address 2.2.2.2 255.255.255.0

R2(config)# interface GigabitEthernet0/1
R2(config-if)# ip address 12.12.12.1 255.255.255.0

R2(config)# interface GigabitEthernet0/2
R2(config-if)# ip address 23.23.23.254 255.255.255.0

R2(config)# router ospf 1
R2(config-router)# network 12.12.12.0 0.0.0.255 area 0
R2(config-router)# network 23.23.23.0 0.0.0.255 area 0
R2(config-router)# network 2.2.2.0 0.0.0.255 area 2
R3(config)# interface Loopback1
R3(config-if)# ip address 3.3.3.3 255.255.255.0

R3(config)# interface GigabitEthernet0/1
R3(config-if)# ip address 23.23.23.1 255.255.255.0

R3(config)# interface GigabitEthernet0/2
R3(config-if)# ip address 13.13.13.254 255.255.255.0

R3(config)# router ospf 1
R3(config-router)# network 13.13.13.0 0.0.0.255 area 0
R3(config-router)# network 23.23.23.0 0.0.0.255 area 0
R3(config-router)# network 3.3.3.0 0.0.0.255 area 3
R1(config)# interface Loopback1
R1(config-if)# ip address 1.1.1.1 255.255.255.0

R1(config)# interface GigabitEthernet0/0
R1(config-if)# ip address 10.10.10.254 255.255.255.0

R1(config)# interface GigabitEthernet0/1
R1(config-if)# ip address 13.13.13.1 255.255.255.0

R1(config)# interface GigabitEthernet0/2
R1(config-if)# ip address 12.12.12.254 255.255.255.0

R1(config)# router ospf 1
R1(config-router)# redistribute rip subnets
R1(config-router)# network 12.12.12.0 0.0.0.255 area 0
R1(config-router)# network 13.13.13.0 0.0.0.255 area 0
R1(config-router)# network 1.1.1.0 0.0.0.255 area 1

R1(config)# router rip
R1(config-router)# version 2
R1(config-router)# redistribute ospf 1 metric 1
R1(config-router)# network 10.10.10.0
R1(config-router)# no auto-summary
RIP(config)# interface Loopback1
RIP(config-if)# ip address 9.9.9.9 255.255.255.0

RIP(config)# interface GigabitEthernet0/0
RIP(config-if)# ip address 10.10.10.1 255.255.255.0

RIP(config)# router rip
RIP(config-router)# version 2
RIP(config-router)# redistribute ospf 1 metric 1
RIP(config-router)# network 9.9.9.0
RIP(config-router)# network 10.10.10.0
RIP(config-router)# no auto-summary

Jika dilihat, pada R1 dan RIP maka ada perintah redistribute. Perintah itu digunakan untuk mendistribusikan tabel routing dari OSPF ke RIP dan sebaliknya.

Periksa apakah tabel routing dari RIP sudah masuk ke OSPF dan sebalinya.

R2# show ip route
show ip route

Jika dilihat pada gambar di atas, maka network 9.9.9.0 sudah masuk di R2. Router R2 mendapatkan informasi tersebut dari router ASBR yaitu R1 yang ditandai dengan O E2.

Begitu juga lihat pada router RIP.

show ip route

Terlihat semua network sudah masuk pada tabel routing di router RIP. Kemudian lakukan tes ping misalkan dari R2 ke router RIP atau sebaliknya. Arahkan tes ping ke loopback.

R2# ping 9.9.9.9
RIP# ping 2.2.2.2

LANJUTKAN BACA MATERI LENGKAP


Leave a Reply

Your email address will not be published.

This site uses Akismet to reduce spam. Learn how your comment data is processed.