14. RIP (Routing Information Protocol)

Screenshot_49

Overview

RIP (Routing Information Protocol) merupakan protokol routing merupakan salah satu protokol routing dinamis berjenis IGP (Interior Gateway Protocol). RIP menggunakan algoritma distance vector dimana akan memilih jalur terbaik berdasarkan jalur terdekat untuk mencapai tujuan. Routing ini tidak cocok digunakan untuk jaringan dengan skala besar, karena masih memungkinkan untuk terjadi loop.

Konsep Dasar RIP

  1. Masing-masing router secara otomatis menambahkan isi tabel routing dengan kode “Directly Connected” ke dalam protokol routing.
  2. Masing-masing router mengirimkan tabel routing dalam bentuk routing updates pada setiap port-nya, yaitu Directly Connected dan rute-rute yang telah dipelajarinya.
  3. Router akan listen pada routing update yang diterima dari router tetangga untuk mempelajari semua jalur.
  4. Routing update akan dikirimkan secara periodik setiap 30 detik.
  5. Routing update hanya memiliki Network ID dan metric. Pada RIP versi 2 memiliki subnet mask juga.
  6. Masing-masing router menambahkan niai 1 pada metric sebelum mengirimkannya lagi.
  7. Alamat tujuan routing update adalah Multicast (RIP v2) atau Broadcast (RIP v1).
  8. Port yang menerima routing update juga akan menjadi outgoing interface.
  9. Jika sebuah router menerima update dengan source IP Address A.B.C.D, maka alamat IP A.B.C.D tersebut akan menjadi next hop Address.
  10. Jika sebuah router mempelajari lebih dari satu jalur untuk menuju ke sebuah jaringan, maka yang akan ditambahkan ke tabel routing adalah jalur dengan metric terkecil.
  11. Setiap router akan melakukan refresh paket hello setiap 30 detik dengan waktu maksimal 180 detik. Jika tidak melakukan refresh dalam batas waktu maksimal, maka router akan dihapus dari tabel routing.
  12. Di dalam RIP, metric adalah jumlah hop dengan maksimal hop adalah 15 (16 adalah infinity).

Konfigurasi RIP v2

Topologi Sederhana RIP
R1(config)# router rip
R1(config-router)# version 2
R1(config-router)# network 10.10.10.0
R1(config-router)# network 14.14.14.0

R2(config)# router rip
R2(config-router)# version 2
R2(config-router)# network 10.10.10.0
R2(config-router)# network 11.11.11.0

R4(config)# router rip
R4(config-router)# version 2
R4(config-router)# network 11.11.11.0
R4(config-router)# network 12.12.12.0

R5(config)# router rip
R5(config-router)# version 2
R5(config-router)# network 12.12.12.0
R5(config-router)# network 13.13.13.0

R3(config)# router rip
R3(config-router)# version 2
R3(config-router)# network 13.13.13.0
R3(config-router)# network 14.14.14.0

Kemudian lakukan tes ping antara router satu dengan yang lain. Untuk melihat tabel dan informasi routing dapat menggunakan perintah di bawah ini.

R1> show ip route
R1> show ip protocol

LANJUTKAN BACA MATERI LENGKAP


Leave a Reply

Your email address will not be published.

This site uses Akismet to reduce spam. Learn how your comment data is processed.